Session keys doesnt work with --unsafe-rpc-external FLag

To connect relayer and make RPC visible outside container I used --unsafe-rpc-external , and it was solution for relayer run BUT with this flag it didint give me set session keys
Can not read properties of undefined (reading ‘slice’)
I decided to remove the flag --unsafe-rpc-external and recreate container. And session keys command worked…
So at this second

  1. with the flag --unsafe-rpc-external RPC is reachable outside container but session keys dont work
  2. with NO flag --unsafe-rpc-external RPC is not reachable outside container (relayer doesnt work) but session keys DO WORK
    Im just now wondering what is the right way to run the node .Because if I run for relayer with flag I cant set session keys, If I run without flag I cant connect relayer…

Out team have updated the manuals using docker for node and relayer both. Such as adding --network host option when you run your docker container. And also required to add http:// in the beginning of your bifrost network url in your relayer configuration file.